AWS us-east-1 issues

Incident Report for Hex

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 09:38 PDT

Monitoring

AWS is experiencing issues in the us-east-1 region that may affect some Hex services for a subset of customers. We are closely monitoring AWS's updates: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 08:04 PDT
This incident affected: Main site and Single tenant stacks.